Microsoft SQL Server is shown as disconnected in Plesk: Unable to determine the TCP port number used by Microsoft SQL server

Posted:  May 14th, 2018

 

Symptoms

 

Microsoft SQL server is shown as disconnected (there is no green checkmark next to the server name) in Plesk in Tools & Settings > Database Servers:

Warning: Unable to determine the TCP port number used by Microsoft SQL server '.\\MSSQLSERVER2014': TCP/IP protocol is not enabled in the server network configuration or the server is configured to use dynamic TCP ports.

To allow your customers to automatically configure firewall for remote database access, manually configure the SQL server to listen on a specific fixed TCP port.

Note: if Microsoft SQL server is shown as connected, the warning can be ignored. However, it is still better to define exact port, to avoid connection issues in future.

Cause

 

An instance of MS SQL Server is not configured to use static ports.

 

Resolution

 

1) Connect to the server using RDP.

 

2) Go to Start > SQL Server XXXX Configuration Manager (where XXXX is a version of MS SQL Server).

 

3) Follow the steps from the Microsoft documentation article Configure a Server to Listen on a Specific TCP Port to configure MS SQL Server instance to use static ports.

 

 Note: During configuring, do not forget to remove the values from the fields TCP Dynamic Ports.

 

If after applying the above solution the warning is still shown in Plesk in Tools & Settings > Database Servers, follow the below steps:

 

    > Log into Plesk.

 

    > Go to Tools & Settings > Database Servers > MS_SQL_Server_name > Settings.

 

    > Specify the port number (which was set in the SQL Server Configuration Manager) in the field Host name or IP address as shown on the screenshot: